Station HP 735/125

Cette page présente les 2 stations hp 735/125 que j'ai récupéré en juillet 2004

Depuis plus d'un an, lorsque je retournais à l'IUT pour revoir un ami qui y travaille de temps en temps, je passais devant un tas de matériel plutôt ancien. Dans ce tas, il y avait 2 cisco, 2 stations HP, 2 baies de disques, quelques tomes de la documentation cisco, des disques en rack et quelques câbles. Autant le dire tout de suite : je bavais copieusement dessus.

Un jour que je retournais à l'IUT pour un apéro, j'ai appris que les stations HP et leurs disques allaient partir à la poubelle, faute de temps pour s'en occuper. Je me suis proposé pour les récuperer, et après de rapides negociation, j'ai eu le droit de venir les chercher.

Le jour J arrive, je sors du boulo et je file en direction de l'IUT avec mon ami6. Une fois là bas, je discutes quelques minutes puis je commence à charger le coffre. Le matériel est très lourd! Je repart chez moi, décharge tout ça dans l'ascenseur puis de l'ascenseur à l'entrée de mon appartement. Creuvé, je n'ai même pas le temps de commencer à démonter, le transport des quelques 100kg de matériel m'ont épuisé. J'ai pris quelques photos ici

Le lendemain, recherche intensive de documentation, pas vraiment fructueuse, mis à part le "service maintenance guide" du model 735/125, rien de bien interessant. Il semblerait que pour le modèle que je possède, il n'y ai pas de pilote pour le controleur fast wide SCSI HVD (High Voltage Differential) sous pa-linux, openBSD, netBSD ou NextStep. Il faudra creuser un peu plus la question. Le bios est en mode texte, et accessible depuis une console sur le port série. Bonne nouvelle vu que je n'ai ni clavier (port hp HIL) ni souris.

Quelques jours après j'ai enfin pensé à ramener du boulo un cable null modem

Nettoyage de font en comble d'une des deux stations et de sa baie de disques, à la souflette. J'ai pris des photos ici


15/07/2004 : j'ai booté la station! je l'ai branchée, reliée à sa baie de disque et à son lecteur de bande, et reliée à un pc via un cable null modem. Dans minicom, j'ai pu voir le test memoire (400Mo, j'ose pas imaginer ce que ça devait coûter à l'époque), la detection des disques durs et le boot de hpux! Je n'avais pas le mot de passe root et ça m'inquiétait un peu, mais une partition n'avais pas été correctement démontée lors d'un boot précédent et sans rien faire je me suis retrouvé avec un prompt root m'indiquant que je devais vérifier la partition manuellement. «Got root»! (photos)

Une fois les partitions vérifiées, j'ai pu continuer de booter. Quelques messages d'erreur plus tard (pas de cable réseau branché, pas de serveur dhcp disponible), je me heurte à un problème plus grave : impossible de monter les lvm : les disques de la baie de disque sont bien reconnus, mais sont inaccessibles (un truc du genre disques déjà en cours d'utilisation). Le système semble complet, mais je n'ai pas accès aux 8Go de la baie de disque. Faute de connaissances en hp-ux, je n'arrive pas à comprendre le message d'erreur, ni à trouver une commande pour diagnostiquer le problème. Avec la commande bcheckrc, le système essaie de monter les lvm, mais echoue invariablement.


17/08/2004 : je n'arrive toujours pas à monter les volumes logiques, il manque apparement le PV (physical volume) où sont stockés les LV (logical volume). Quelques infos utiles ici : http://bhami.com/rosetta.html. Je vais peut-être laisser tomber et tenter de recréer les partitions dont j'ai besoin.


24/03/2005 : toujours pas de solution pour hpux, j'ai pu récupérer les cds d'installation de hp-ux 10.20, mais pour la série hp800. Toutes mes tentatives de démarrage se soldent par «IPL error: bad LIF magic». Je ne suis pas vraiment surpris, ce ne sont pas exactement les bons CDs, juste un peu déçu.

J'ai tenté aussi de booter par le réseau pour en faire des diskless workstation. Ça se passe avec rbootd pour ce modèle de station (au lien de bootp + tftp). La station détecte bien le serveur, et commence bien le chargement du fichier (noyau + lif) mais à chaque fois je tombe sur l'erreur «IPL error: bad LIF checksum». J'ai pourtant testé le fichier de boot de netsd, openbsd et linux, à chaque fois la même erreur.

Je vais retenter ce soir de booter sur un cd de debian/hppa et des cds de www.pateam.org. Je vais aussi essayer en changeant la version de rbootd, de netbsd à debian woody.


25/03/2005 : j'ai enfin trouvé le problème concernant le démarrage depuis le réseau : le rbootd de netbsd ne semble pas fonctionner. En installant rbootd version 2.0 sur la debian woody, j'ai pu booter les fichiers lif sans problème. J'avais un lecteur de cd scsi externe, en remplaçant le lecteur de cd par un disque dur scsi (2,5 pouces), me voila avec une machine prête à acceuillir OpenBSD :) L'installation est d'ailleur en cours. Pour que tout soit parfait, il ne manque plus qu'un pilote pour le controleur scsi HVD NCR 53C720 FW-SCSI (et accessoirement un écran, un clavier et une souris).

N'oublions pas le fichier dmesg qui comporte toujours tout un tas d'info utiles.

Prochaine étape : voir si l'écran IBM 6091 19i prévu pour les rs6000 permet d'afficher quelque chose sur les hp. Il faut juste que je trouve un câble BNC-BNC. Je n'y crois pas trop, je ne sais pas si l'écran support la synchro sur le vert et si la fréquence et la résolution seront correctes, et oui, c'est un écran mono-sync.

Un petit détail sympatique sur cette machine : il y a un voyant (le numéro 4) qui correspont au battements de coeur! Dès que le système d'exploitation est chargé, ce voyant clignote sans interuption. Est-ce pour savoir si la machine est plantée ou non?


m'écrire : busab@nerim.net

Dernière mise à jour : vendredi 25 mars 2005 à 22 heures 14

Valid XHTML 1.1! (cette page a été créée sous amaya, et retouchée sous vim)